ARBER System Requirements

This page last reviewed October 29, 2009.

This page lists the system requirements for ARBER.  ARBER was designed to be used with the most popular browser software, specifically, Microsoft's Internet Explorer 7 and Mozilla's Firefox 2.  If your browser is older than the versions mentioned, we recommend you upgrade your browser software to the latest version before using ARBER.

System Requirements

Note: In order for you to print the certification page correctly, you may need to adjust your printer settings depending on your browsers.  To download the printing instructions, click here.

preload